19. Два игрока, Сергей и Анатолий, играют в следующую игру. Перед игроками лежат две кучи камней. Игроки ходят по очереди, 
первый ход делает Сергей. За один ход игрок может из каждой кучи убрать по три камня или убрать целиком одну кучу, а другую 
разделить на две равные (если это позволяет количество камней).
Игра завершается после того хода, когда хотя бы одна куча становится пустой или когда невозможно сделать очередной ход по правилам. 
Побеждает тот, кто сделал последний ход. В начальный момент времени в одной куче лежит N камней, а в другой — К камней.
Будем говорить, что игрок имеет выигрышную стратегию, если он может выиграть при любых ходах противника. Описать стратегию игрока — 
значит описать, какой ход он должен сделать в любой ситуации, которая ему может встретиться при различной игре противника.

19. Известно, что после неудачного первого хода Сергея Анатолий выиграл первым своим ходом. При каком наибольшем значении К это возможно, 
если N = 32?

20. Найти все такие значения К при которых у Сергея есть вигрышная стратегия:
- Сергей не может выиграть за один ход;
- Сергей может выиграть своим вторым ходом независимо от того, как сыграет Анатолий.

21. При N = 20, найти наибольшее значение K, при котором у Анатолия есть выигрышнаяя стратегия, позволяющая ему
выиграть своим первым или вторым ходом.

def f(s1,s2,m):
    if s1==0 or s2==0: return m%2==0


    h = []
    if s1>=3 and s2>=3: h.append(f(s1-3,s2-3,m-1))
    if s1%2==0: h.append(f(s1//2, s1//2,m-1))
    if s2%2==0: h.append(f(s2//2, s2//2,m-1))
    if len(h)==0: return m%2==0
    if m == 0: return 0

    return any(h) if (m-1)%2==0 else all(h)

print('№19',[s for s in range(1,60) if f(32,s,2)]) #[4, 5, 6, 8]
print('№20',[s for s in range(1,60) if f(32,s,3) and not f(32,s,1)]) #[8, 9, 10, 12, 14]
print('№20',[s for s in range(1,60) if f(20,s,4) or f(32,s,2)]) #[1, 5, 6, 13, 15, 17]

